I got an error that says “You have not chosen to trust ‘DigiCert High Assurance CA-3.” What do I do?

This means you may have an older version of the Citrix plugin. You need to upgrade Citrix.

Click here to upgrade Citrix for PC.
Click here to upgrade Citrix for Mac.

If you’re still running into trouble, contact our Support Desk by clicking here, or calling 877-907-2186 (24/7).